login   |    register
Modeling in General
General discussions about modeling topics.
Ryefield VW - Anybody get one yet?
ivanhoe6
Visit this Community
Wisconsin, United States
Member Since: April 05, 2007
entire network: 1,731 Posts
KitMaker Network: 531 Posts
Posted: Tuesday, June 25, 2019 - 04:01 AM UTC
Saturday, I received my new Ryefield VW release. The kit looks great!! BUT, it was missing the vinyl tires So I contacted Sprue Bros. via Email and told them about it. I just took a call from a LIVE person at Sprue Bros. He had opened another kit and it too was missing the tires. He was now going to do some more investigating on the matter and Sprue Bros was going to make it right.
WOW ! A live person vowing to make it right ! This is the best customer service I have ever received from an online vendor !

Anyway, has anybody bought one yet ? If so, did you get the vinyl tires? Just trying to figure out if it's all kits or just the batch Sprue received.
ivanhoe6
Visit this Community
Wisconsin, United States
Member Since: April 05, 2007
entire network: 1,731 Posts
KitMaker Network: 531 Posts
Posted: Tuesday, June 25, 2019 - 11:44 PM UTC
UPDATE: Just checked Emails and there was one from Sprue Bros. It sounded like that they opened boxes until they found a set of tires. They are now being shipped First Class mail.
BEST customer service I've ever dealt with !
SSGToms
Visit this Community
Connecticut, United States
Member Since: April 02, 2005
entire network: 3,466 Posts
KitMaker Network: 497 Posts
Posted: Thursday, July 04, 2019 - 04:23 AM UTC
I received mine Friday from HobbyEasy. The rubber tires were in the box. What a true jewel of a kit! The full body 1 piece molding is amazing! It had to be a 4 part slide mold and there's not a seam on it. The detail throughout the kit is amazing. I can't see anywhere where it could use PE or scratch detailing. I am duly impressed.
ivanhoe6
Visit this Community
Wisconsin, United States
Member Since: April 05, 2007
entire network: 1,731 Posts
KitMaker Network: 531 Posts
Posted: Monday, July 08, 2019 - 04:35 AM UTC
Glad to hear you had no problems Matt ! Mine must have been packed on a Monday.
It is a true gem and about time too ! Enjoy building it !